Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Network Event: Provider Down

Incident Report for OIT Status Page

Resolved

Our Internet Service Provider restored service on Friday, March 27, around 6:30 PM ET.
Posted Mar 30, 2026 - 11:22 EDT

Investigating

One of the two internet service providers for the University of Tennessee is currently down as of 1:44 PM EDT. OIT personnel are engaging with the provider. There is not an ETA for repair at this time.
Posted Mar 27, 2026 - 14:50 EDT
This incident affected: Internet, Networking, & Infrastructure (Network).