Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

MyPrint Issues

Incident Report for OIT Status Page

Resolved

The issues with MyPrint have been resolved.
Posted Apr 06, 2026 - 15:51 EDT

Investigating

We are currently experiencing issues with MyPrint that may prevent some printers from appearing in the print selection menu. OIT is actively working with the vendor to identify and resolve the issue.

In campus computer labs, users can print successfully by printing directly (normal print) rather than using MyPrint on the lab computer.
Posted Mar 18, 2026 - 13:03 EDT
This incident affected: Computer, Mobile, & Software (VolPrint).