Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

TeamDynamix Work Management and Service Portal Performance Degradation

Incident Report for OIT Status Page

Resolved

TeamDynamix is rolling back a chance made over the weekend that casued today's performance issues. Service to TDX and the OIT Service Portal has been fully restored.
Posted Jun 02, 2025 - 15:13 EDT

Investigating

TeamDynamix (TDX) is actively investigating reports of performance degradation this morning. This issue affects TDX users and Service Portals, such as the OIT Service Portal.
Posted Jun 02, 2025 - 09:24 EDT
This incident affected: Academic & Administrative Services (TeamDynamix (TDX)).