Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Microsoft 365 Outage

Incident Report for OIT Status Page

Resolved

The Microsoft 365 access issues have been resolved.
Posted Oct 10, 2025 - 08:34 EDT

Investigating

Microsoft is investigating intermittent access issues to Microsoft 365 services.
Posted Oct 09, 2025 - 14:58 EDT
This incident affected: Email, Collaboration, & Teamwork (Microsoft 365).