Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Network Outage - Student Health Building

Incident Report for OIT Status Page

Resolved

Network connectivity has been restored to the Student Health Building.
Posted Feb 26, 2026 - 10:18 EST

Update

We are continuing to investigate this issue.
Posted Feb 22, 2026 - 11:02 EST

Investigating

Due to a partial power outage in the Student Health Building, both wired and wireless network access is currently unavailable. Facilities Services has been notified.
Posted Feb 22, 2026 - 07:45 EST
This incident affected: Internet, Networking, & Infrastructure (Network).