Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Argos Production Environment unavailable

Incident Report for OIT Status Page

Resolved

Access to Argos Production has been restored.
Posted Nov 24, 2025 - 13:59 EST

Investigating

Argos Production Environment is currently unavailable to all Argos users. OIT is working to resolve the issue.
Posted Nov 24, 2025 - 08:29 EST
This incident affected: Academic & Administrative Services (Argos).