Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

MyUTK Unavailable

Incident Report for OIT Status Page

Resolved

Access to MyUTK and other web applications hosted on the webapps.utk.edu servers has been restored.
Posted Aug 18, 2025 - 13:42 EDT

Investigating

OIT is investigating intermittent issues affecting myUTK and other web applications hosted on the webapps.utk.edu servers. Users may encounter a “503 Service Unavailable” error when visiting these sites.
Posted Aug 18, 2025 - 10:24 EDT
This incident affected: Academic & Administrative Services (MyUTK).