Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 11, 2024 - 07:00 EST
Scheduled
OIT will perform Argos updates to the Argos Development (DEV) Environment on Monday, November 11, from 7:00 AM to 8:00 AM. During this time, the Argos DEV Environment will be unavailable.
Posted Nov 06, 2024 - 16:04 EST
This scheduled maintenance affected: Academic & Administrative Services (Argos).