Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 11, 2024 - 13:00 EST
Scheduled
OIT will be patching Sunapsis Development with the latest application patch today, November 11, from 1 PM until 5 PM EST. If you have any questions regarding this maintenance, please call the OIT HelpDesk at (865) 974-9900.
Posted Nov 11, 2024 - 11:51 EST
This scheduled maintenance affected: Academic & Administrative Services (Student Information Systems).