Office of Innovative Technologies
Get the Atom Feed or RSS Feed.

OIT HelpDesk  |  OIT Home

OIT Status Page

Zoom Outage

Incident Report for OIT Status Page

Resolved

Zoom service has been restored.
Posted 16 days ago. Apr 16, 2025 - 17:12 EDT

Investigating

Zoom is currently experiencing an outage affecting users. We are monitoring the situation and will provide an update once the issue is resolved.
Posted 16 days ago. Apr 16, 2025 - 15:39 EDT
This incident affected: Email, Collaboration, & Teamwork (Zoom).