Office of Innovative Technologies

OIT HelpDesk  |  OIT Home  |  OIT Scams Site
Outlook Web Access Search Unavailable
Incident Report for OIT Status Page
Resolved
Microsoft has restored the search functionality in Outlook on the web.
Posted Nov 11, 2024 - 11:38 EST
Investigating
Some users may be unable to search their email in Outlook on the web and may see an error message: "Something went wrong. Please try again later." Users can search their email using the Outlook desktop app. Microsoft are actively investigating and working to resolve the issue.
Posted Oct 30, 2024 - 09:43 EDT
This incident affected: Email, Collaboration, & Teamwork (Microsoft 365).