Access to Microsoft 365 services and features has been restored. Microsoft will continue monitoring these services to ensure the availability remains stable.
Posted Nov 26, 2024 - 08:49 EST
Investigating
Users may be unable to access or use some Microsoft 365 services and features. The affected services include Exchange Online, Microsoft 365 suite, Microsoft Power Automate in Microsoft 365, Microsoft Purview, Microsoft Teams, SharePoint Online, and Universal Print. The issue started on November 24, 2024, at 9:54 PM EST and is currently classified as a service degradation.
Microsoft is actively working on resolving the issue and has deployed a fix to approximately 60% of the affected environments. They are continuing manual restarts on the remaining impacted machines.
Posted Nov 25, 2024 - 10:55 EST
This incident affected: Email, Collaboration, & Teamwork (Microsoft 365).