Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Canvas and Canvas Catalog Unavailable

Incident Report for OIT Status Page

Resolved

Instructure has restored access to Canvas and Canvas Catalog.
Posted May 08, 2026 - 07:54 EDT

Identified

Canvas is unavailable nationwide due to a cybersecurity incident affecting educational institutions across the country. We do not know when service will be restored. Instructure, Canvas’ parent company, has posted a status page to share updates on the outage (https://status.instructure.com/).
Posted May 07, 2026 - 17:33 EDT
This incident affected: Teaching, Learning, & Research (Canvas).