Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Vol Connect Performance

Incident Report for OIT Status Page

Resolved

SalesForce services have returned to normal performance.
Posted Jun 22, 2026 - 14:08 EDT

Investigating

Our SalesForce instance is affected by a known performance degradation issue. SalesForce engineers are working to restore normal performance. Users may notice slow or unexpected behavior until full service is restored.
Posted Jun 18, 2026 - 12:35 EDT
This incident affected: Academic & Administrative Services (Vol Connect).