Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OneIT Status Page

Forms.utk.edu unavailable

Incident Report for OneIT Status Page

Resolved

Access to Forms.utk.edu has been restored.
Posted Jul 31, 2026 - 08:57 EDT

Investigating

Forms.utk.edu is unavailable. System administrators are aware of the issue.
Posted Jul 24, 2026 - 19:27 EDT
This incident affected: Web & Application Hosting (UT/OIT Websites).