Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Netreg Unavailable

Incident Report for OIT Status Page

Resolved

Access to Netreg has been restored.
Posted Jun 05, 2025 - 13:45 EDT

Investigating

Netreg is currently unavailable. OIT administrators are investigating.
Posted Jun 05, 2025 - 08:32 EDT
This incident affected: Internet, Networking, & Infrastructure (NetReg).