Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 04, 2024 - 01:00 EDT
Scheduled
RingCentral will be performing availability testing on the RingCentral network on Saturday, October 5, from 1 AM until 7 AM EST. During this time, Ring Central calls, faxes, and video meetings may be disconnected. If you have any questions regarding this announcement, please contact the OIT HelpDesk at (865) 974-9900.
Posted Sep 13, 2024 - 15:55 EDT
This scheduled maintenance affected: Phones, Conferencing, & Cable TV (RingCentral).