Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Cloud Service Issues

Incident Report for OIT Status Page

Resolved

Microsoft 365, Azure, AWS, and Google Cloud Services have resumed regular service.
Posted Oct 30, 2025 - 08:47 EDT

Investigating

Multiple cloud services, including Microsoft 365, Azure, AWS, and Google, are experiencing a degradation in service. You may have issues accessing these services and more, until it's resolved.
Posted Oct 29, 2025 - 13:10 EDT
This incident affected: Email, Collaboration, & Teamwork (Microsoft 365).