Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Qualtrics Unavailable

Incident Report for OIT Status Page

Resolved

Access to Qualtrics has been restored.
Posted Oct 30, 2025 - 09:07 EDT

Identified

The Qualtrics login issues stem from the employee login issues this morning. OIT is actively investigating and working to restore access
Posted Oct 29, 2025 - 11:57 EDT

Investigating

OIT is investigating login issues with Qualtrics. Qualtrics is unavailable at this time.
Posted Oct 29, 2025 - 10:53 EDT
This incident affected: Teaching, Learning, & Research (Qualtrics).