Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Duo Logins Unavailable on Azure/Entra

Incident Report for OIT Status Page

Resolved

The issue causing 504 gateway timeouts when attempting to authenticate with Duo has been resolved.
Posted Feb 23, 2026 - 13:27 EST

Investigating

Duo is investigating an issue where 504 Gateway timeouts occur when attempting to use Duo for Azure/Entra logins (including Microsoft 365).
Posted Feb 23, 2026 - 10:22 EST
This incident affected: Accounts & Access Management (Duo 2FA).