Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Qualtrics Outage

Incident Report for OIT Status Page

Resolved

Access to Qualtrics has been restored.
Posted Oct 21, 2025 - 08:23 EDT

Investigating

Qualtrics is investigating issues with platform access and support request submissions. Qualtrics is unavailable at this time.
Posted Oct 20, 2025 - 11:03 EDT
This incident affected: Teaching, Learning, & Research (Research Software).