Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

25 Live Room Scheduling System Unavailable

Incident Report for OIT Status Page

Resolved

Access to the 25 Live Room Scheduling system has been restored.
Posted Jan 29, 2026 - 11:04 EST

Investigating

The 25 Live Room Scheduling system at 25live.utk.edu is unavailable this morning. The vendor has been notified.
Posted Jan 29, 2026 - 09:58 EST
This incident affected: Academic & Administrative Services (Student Information Systems).