Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

My UTK Schedule Printing

Incident Report for OIT Status Page

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 21:00 EST

Investigating

OIT administrators are investigating an issue affecting the display and printing of student schedules in MyUTK following Saturday’s maintenance.
Posted Feb 16, 2026 - 09:39 EST
This incident affected: Academic & Administrative Services (MyUTK).