Office of Innovative Technologies

OIT HelpDesk  |  OIT Home  |  OIT Scams Site
Apps@UTK
Incident Report for OIT Status Page
Resolved
Access to applications on Apps@UT has been restored.
Posted Sep 25, 2024 - 16:19 EDT
Investigating
Some users are experiencing issues when trying to open an application from apps.utk.edu. We are investigating this issue.
Posted Sep 25, 2024 - 14:14 EDT
This incident affected: Computer, Mobile, & Software (Apps@UT).