Office of Innovative Technologies

OIT HelpDesk  |  OIT Home

OIT Status Page

Hyper-V Issues

Incident Report for OIT Status Page

Resolved

The Hyper-V cluster issue is resolved.
Posted Jun 05, 2025 - 16:07 EDT

Investigating

OIT is currently experiencing issues with our Hyper-V Cluster. Administrators are looking into the issue.
Posted Jun 05, 2025 - 15:00 EDT
This incident affected: Servers, Storage, & Backups (Windows System Administration).